Переход с Joomla 3 на 4

Переход с Joomla 3 на 4

2 комментария

Пошаговое руководство по обновлению CMS Joomla 3 до Joomla 4. Вы узнаете, что нужно подготовить и проверить, чтобы избежать проблем с работой сайта после перехода на Joomla 4.

Если ваш сайт работает на Joomla версии 3, то в настоящее время вы уже наблюдаете такое уведомление всякий раз, когда заходите в админку своего сайта:

Текст предупреждения на английском
Joomla 3.10 has entered security only mode. Support ends 17 August 2023. Start planning to migrate to Joomla 4 today.
Текст предупреждения на русском
Поддержка версии Joomla 3.10 будет прекращена 17 августа 2023 и сейчас получает только исправления безопасности.

Это значит, что:

  1. Функционал ядра Joomla 3 больше не будет расширяться.
  2. Обновления Joomla 3 выходят только по части исправления выявленных багов и уязвимостей.
  3. После 17 августа 2023 года для Joomla 3 больше не будет выходить никаких обновлений.

Поэтому чем раньше вы начнёте процесс переноса своего сайта на Joomla 4, тем с меньшим количеством проблем вам предстоит столкнуться.

Зачем переходить на Joomla 4?

Joomla 4 на данный момент является актуальной основной версией CMS, которая постоянно обновляется в отношении функционала:

  • расширяются функциональные возможности ядра,
  • создаются новые и улучшаются существующие сторонние расширения,
  • Joomla 4 базируется на самых современных веб-технологиях, что делает её более производительной.

Однако всё это не значит, что вы обязательно должны обновить свой сайт с Joomla 3 до 4. Причины не обновляться могут быть следующие:

  1. Вашему сайту не требуется ни какой дополнительный функционал, он просто существует и наполняется новым контентом, и на нём уже есть все необходимые функциональные возможности.
  2. На сайте множество сторонних расширений, не совместимых с новой версией Joomla, либо не подходящих под её системные требования.

И если в первом случае вы можете себе позволить вообще не думать о переходе на Joomla 4, то во втором случае всё иначе: чем дольше вы будете отлаживать миграцию, тем болезненнее будет процесс.

Почему нельзя просто обновить Joomla 3 до 4?

Три основные причины:

  1. Версия Joomla ниже, чем 3.10.
  2. Несоответствие системным требованиям.
  3. Несовместимость сторонних расширений.
Примите к сведению
Если ваш сайт работает на Joomla версии ниже 3.10, то первым делом необходимо обновиться до 3.10.

Привести сервер в соответствие системным требованиям обычно не составляет проблем. Как правило, это легко делается через панель управления хостингом. Однако подводный камень заключается в том, что после обновления ПО под Joomla 4, может перестать функционировать ваш текущий сайт, работающий на Joomla 3. Во избежание таких проблем достаточно привести сервер к минимальным требованиям для Joomla 4, которые годятся для Joomla 3. Если же после изменения версий ПО сайт перестанет работать, то просто верните предыдущие настройки.

Что касается расширений, то здесь всё сложнее, т. к. возможно некоторые расширения уже никогда не будут адаптированы под новую версию Joomla. Поэтому сперва нужно определить, совместимы ли расширения вашего сайта с Joomla 4.

Проверка перед обновлением (Pre-Update Check)

Joomla 3.10 является переходным мостом, в которой предусмотрена проверка соответствия функционала сайта новой версии CMS. Инструкция по активации проверки:

  1. Компоненты → Обновление JoomlaНастройки 
    Вы попадёте на страницу настроек компонета обновлений Joomla.
  2. Сервер обновленийJoomla! NextСохранить и закрыть 
    Вы попадёте на страницу Проверка перед обновлением.
  3. Ознакомьтесь c результами проверки
    Теперь вы сможете запускать проверку перед обновлением, переходя в Компоненты Обновление Joomla.

Инструмент Проверка перед обновлением проверяет:

  • Требуемые параметры PHP и БД
  • Рекомендуемые параметры PHP
  • Совместимость расширений

Если какие либо параметры не соответствуют, то кликните Подробнее, чтобы узнать, какие параметры следует привести в соответствие.

Требуемые параметры PHP и БД

Успешная проверка данных параметров обязательна. Привести сайт в соответствие необходимым требованиям по этим пунктам можно в панели управления хостингом. Если же какие-либо параметры вы не сможете там найти, то обратитесь в службу поддержки хостера либо к своему системному администратору.

Рекомендуемые параметры PHP

Полное соответствие данным параметрам не обязательно. Найти и изменить их можно аналогично в настройках PHP через панель управления хостингом.

Проверка расширений перед обновлением

Этот этап проверки может вызывать больше всего проблем в зависимости от количества установленных сторонних расширений.

Здесь возможны такие результаты:

  1. Не удалось выполнить проверку перед обновлением
    Расширения, которые попадают под такой результат, скорее всего, не совместимы с Joomla 4. Вы можете попробовать найти информацию о совместимости в каталоге расширений Joomla. Несовместимое с Joomla 4 расширение надо либо удалить/отключить, либо попробовать найти альтернативы.
  2. Информация о совместимости недоступна 
    В данном случае также следует обратить внимание на информацию о совместимости в JED, либо на сайте разработчика. Если расширение отмечено как совместимое только с Joomla 3, то от него также придётся отказаться. Однако если расширение является языковым файлом или пакетом, то можно спокойно закрыть на это глаза.
  3. Требуется обновление расширений
    Необходимо обновить эти расширения до актуальных версий, чтобы привести их к совместимости с Joomla 4.
  4. Обновление расширений не требуется
    Эти расширения должны нормально функционировать после обновления CMS.

Напротив названий отдельных расширений может быть уведомление Потенциальная проблема, если вы кликните по слову Подробнее рядом с таким уведомлением, то во всплывающем окне увидите следующий текст:

Текст уведомления
Расширение включает в себя плагин, который может вызвать проблемы во время обновления и привести к недоступности сайта. Для безопасного обновления Joomla необходимо обновить расширение до совместимой версии или отключить соответствующий плагин.

Такие уведомления выводятся напротив пакетных расширений, которые включают в себя компонент/модуль и плагин или несколько плагинов (в таком случае будет отображаться несколько уведомлений).

Что делать:

  1. Проверьте совместимость такого расширения в JED или на сайте разработчика. Если оно совместимо только с Joomla 3, то лучше его удалить вместе со всеми плагинами.
  2. Если оно совместимо с Joomla 4, то:
    1. Убедитесь, что на сайте применяется последняя версия расширения, либо обновите его.
    2. Отключите плагины данного расширения перед обновлением до Joomla 4, после чего активируйте их.

Процесс миграции до Joomla 4

Важная информация!
Даже если Проверка перед обновлением по всем пунктам будет успешной, следует сделать бэкап сайта для перестраховки, чтобы вы могли быстро его восстановить.

После того, как вы приведете свой сайт в соответствие требованиям для Joomla 4:

  1. создайте резервную копию сайта;
  2. разверните данный бэкап на поддомене, чтобы к нему применялись параметры PHP основного сайта;
  3. войдите в админку;
  4. Компоненты Обновление Joomla → Автоматическое обновление → Обновить;
  5. при успешном обновлении сайт примет облик Joomla 4 и вы увидите сообщение «Ваш сайт успешно обновлен до версии Joomla 4»:
  6. теперь можно осуществить миграцию рабочей версии сайта по той же схеме.

Видеоинструкция

Упоминаемые термины:

JED, Joomla, PHP, Админка Joomla, CMS, Бэкап

Напишите комментарий...
или разместить как гость
Пользователи в беседе:
Загрузка комментария... Комментарий будет обновлен после 00:00.